Why do I have to do separate logins to read profiles?

Amity Slade

Active member
Joined
Sep 24, 2018
Messages
60
SL Rez
2007
Joined SLU
Oct 2010
SLU Posts
3965
This is a problem that seems to afflict me intermittently, and has been routine for about a week now.

I am already logged into Second Life and inworld. I see someone, I click on them to read their profile. The profile window comes up in the in-world, but the full profile does not show and there is a padlock icon on the left. To read the profile, I must click on the padlock icon, which takes me to the Second Life main website to login. After I login, and tick the "remember me" box as if it will help, the profile shows up. The next time I want to read a profile, it is locked, and I have to rinse-and-repeat.

What is the deal with that?
 

Chin Rey

Lag fighter
Joined
Oct 28, 2018
Messages
382
Location
Norway
SL Rez
2013
This is a problem that seems to afflict me intermittently, and has been routine for about a week now.
It's a problem that has come and gone over and over again the last few years and they've never managed to fix it. The last I heard was that they were going to give up on the "modern" profile system and revert back to the old one.

The finest of LL coding technology?
The "modern" profiles link to the my.secondlife.com web site through the viewer's integrated web browser, neither of which were developed by LL. (The web browser is an open source one, my.secondlife.com started as an independently run "Facebook for virtual world avatars" before it was bought out by LL.) LL has never managed to get that web browser to work properly and that's where the problem is.
 
Last edited:
  • 2Thanks
Reactions: Brenda Archer and Sid

Amity Slade

Active member
Joined
Sep 24, 2018
Messages
60
SL Rez
2007
Joined SLU
Oct 2010
SLU Posts
3965
So while I was logged in and seeing every profile locked, a brief power outage knocked me offline. I was able to log back in within about five minutes, and profiles were working normally.

I logged out and came back a couple of hours later, and the profiles are all locked again.
 
  • 1Thanks
Reactions: Brenda Archer

Free

Kamilah is stalking me
VVO Supporter 🍦🎈👾❤
Joined
Sep 22, 2018
Messages
4,858
Location
Underground in America
SL Rez
2008
Joined SLU
May 2009
SLU Posts
55565
I have basically not used the official viewer in forever. I didn't even know there were new profiles.
I've been using it steadily, and I didn't know, either. :ashamed:
 

Chin Rey

Lag fighter
Joined
Oct 28, 2018
Messages
382
Location
Norway
SL Rez
2013
I have basically not used the official viewer in forever. I didn't even know there were new profiles.
"New" i s a relative term. I don't know when SL introduced the web profiles but they were already in place when I joined six years ago.
 

Katheryne Helendale

🐱 Kitty Queen🐱
Joined
Sep 20, 2018
Messages
2,513
Location
Right... Behind... You...
SL Rez
2008
Joined SLU
October 2009
Sounds like a single-signon system that is misconfigured. Or it could be a cookie problem. Have you tried clearing your browser's cookies and trying again?

I've never liked the "new" web profiles. Too much intrusion of real life into my SL. But they're not exactly new anymore. I think they came out about 8-9 years ago.
 
  • 1Agree
Reactions: Brenda Archer

Amity Slade

Active member
Joined
Sep 24, 2018
Messages
60
SL Rez
2007
Joined SLU
Oct 2010
SLU Posts
3965
Sounds like a single-signon system that is misconfigured. Or it could be a cookie problem. Have you tried clearing your browser's cookies and trying again?
I use the built-in web browser on the viewer. I don't think there is a "clear cookies" option. I have tried clear cache to no avail.

Profiles were still locked, requiring a signing for each profile, on Friday. On Saturday, they were back to working normally.

How widespread is this issue for people? I have always suspected that profiles just don't load right for me. Sometimes I can't enlarge pictures, sometimes the profile picture and the chat thumbnail don't match, sometimes the text in the profile doesn't match the text preview when you mouse-hover the person and click "i". I've always wondered if there's some setting I don't have set correctly.
 
Joined
Sep 21, 2018
Messages
144
Location
Scotland
Joined SLU
July 2007
SLU Posts
319
I never use the built-in browser because it takes so long to load for me anyway.
 
  • 1Agree
Reactions: Sid

Sid

Today's good mood is sponsored by coffee.
VVO Supporter 🍦🎈👾❤
Joined
Sep 20, 2018
Messages
1,967
Location
NL
SL Rez
2007
Joined SLU
2009
I can almost brew a fresh cup of coffee before the build in browser has loaded a page.