HALP Blender 2.8 Texturing

Clara D.

FOR PRESIDENT 2020!
Joined
Dec 24, 2018
Messages
2,240
Location
Phoenix, AZ, USA
SL Rez
2006
Joined SLU
Back in the day.
SLU Posts
100000000
Okay, I "mostly" have a grasp on the new interface, but texturing eludes me.

I've loaded up some old projects and I can't figure out what I did before to make this work:

I have a simplistic cube-based object that's approximately 0.3x0.3x0.3 and a text-display mesh I want to be able to apply in-world textures to @ 1:1.

Also, how do I get the bar at the top (mode, view, select,add,mesh,etc) down to the bottom?

I don't cope well with video tutorials @.@
 

Knutz Scorpio

Well-known member
Joined
Sep 20, 2018
Messages
212
SL Rez
2010
Joined SLU
02-15-2014
The simple way I used in the old interface to apply textures to my models doesn't work in this new interface. The new way I've learned to do it is;

1. Click "Shading" at the top takes me to the predefined workspace for shading.
2. Bottom right window has two box shaped "nodes" in it attached to each other by a line, you'll need to add another node to this for your texture;
1) Click the "Add" menu, go to the "Texture" submenu, and select "Image Texture"
2) A new node should appear, you need to create a new connection from its "Color" to the "Base Color" of the "Principled BSDF" node.
a. You'll probably have to drag the new node over to the left so it's not sitting on top of the other nodes.
b. By clicking on the "Color" yellowed circle and dragging you'll create a new line, drag it over to "Base Color" to make the connection.
3) If you managed to decipher and follow my instructions your object in the above window will turn black.
3. Within the node you just created and connected is a file folder icon you can click to find the texture file you want to apply.

Relocating the top bar is easier.

1. At the top click the Edit menu then "Preferences ..."
2. In the Interface section under Editors is "Header Position" which you can change to Bottom
 
  • 1Thanks
Reactions: Clara D.

Clara D.

FOR PRESIDENT 2020!
Joined
Dec 24, 2018
Messages
2,240
Location
Phoenix, AZ, USA
SL Rez
2006
Joined SLU
Back in the day.
SLU Posts
100000000
The simple way I used in the old interface to apply textures to my models doesn't work in this new interface. The new way I've learned to do it is;

1. Click "Shading" at the top takes me to the predefined workspace for shading.
2. Bottom right window has two box shaped "nodes" in it attached to each other by a line, you'll need to add another node to this for your texture;
1) Click the "Add" menu, go to the "Texture" submenu, and select "Image Texture"
2) A new node should appear, you need to create a new connection from its "Color" to the "Base Color" of the "Principled BSDF" node.
a. You'll probably have to drag the new node over to the left so it's not sitting on top of the other nodes.
b. By clicking on the "Color" yellowed circle and dragging you'll create a new line, drag it over to "Base Color" to make the connection.
3) If you managed to decipher and follow my instructions your object in the above window will turn black.
3. Within the node you just created and connected is a file folder icon you can click to find the texture file you want to apply.

Relocating the top bar is easier.

1. At the top click the Edit menu then "Preferences ..."
2. In the Interface section under Editors is "Header Position" which you can change to Bottom
Oho, I figured out to do the nodes the other way round! And that I wanted a "Shader" instead of the "Node Editor" workspace o_O

I still have yet to figure out face-based instead of object-based mapping though.

Workflow thus far.... (first part is just notes for myself to reset Blender)
=====
File -> Defaults -> Load Factory Settings
Edit -> Preferences
-> Themes -> Presets -> Blender Light
-> Interface -> Editors -> Header Position -> Bottom
[Save Preferences]

"Join Area" to get rid of timeline at bottom
"Split Area" on right, switch to Texture Node Editor
"Split Area" on main, switch to Shader Editor
[Save as a Default file]

Pop out "Transform" thing on main viewport
Dimension Object to 0.333x0.333x0.333 (or Scale to 0.167x0.167x0.167)
Object -> Apply -> All Transforms

Edit Mode

Face -> Face Data -> Roate UV (Easiest to do *before* I start carving it up :)

Properties Editor -> Materials
Use Nodes Highlighted
Hit the dot on Base Color -> Image Texture
Open -> (Image Dialog)
Change Flat to Box
Change Vector to Texture Coordinate -> Generated
====
OPTIONAL BIT
Surface Specular
Emissive Color
(I use a simple test pattern, but I want to be able to tell "faces" apart.
===
Shading window
node map at bottom -> add -> vector -> mapping (this adds scaling/rot/offset)


 
Last edited:

Clara D.

FOR PRESIDENT 2020!
Joined
Dec 24, 2018
Messages
2,240
Location
Phoenix, AZ, USA
SL Rez
2006
Joined SLU
Back in the day.
SLU Posts
100000000
Hrms. The texture scaling gets all screwed up when I import to SL o_O
 

Knutz Scorpio

Well-known member
Joined
Sep 20, 2018
Messages
212
SL Rez
2010
Joined SLU
02-15-2014
Typically I UV unwrap the model then export the UV map to use in GIMP to create the texture. Within Blender I don't do much more with textures then apply them to my models to make sure they look right.

Texture scaling being messed up in SL, my guess it's yet another mesh thing SL hasn't implemented. In SL could try changing the Mapping to Planar.
 

Clara D.

FOR PRESIDENT 2020!
Joined
Dec 24, 2018
Messages
2,240
Location
Phoenix, AZ, USA
SL Rez
2006
Joined SLU
Back in the day.
SLU Posts
100000000
Typically I UV unwrap the model then export the UV map to use in GIMP to create the texture. Within Blender I don't do much more with textures then apply them to my models to make sure they look right.

Texture scaling being messed up in SL, my guess it's yet another mesh thing SL hasn't implemented. In SL could try changing the Mapping to Planar.
I wanted to use inworld textures with minimal fuss and because it's for a vending machine, I needed XYText faces, the main face, and the fan in the top to all be 1:1

I was derping on the UV parts, the whole thing had to to have the faces "scaled to bounds" to work as expected. Fixed it with help from this video:


VICTORY!





Tomorrow I get to experience the joy of making proper lower-LOD versions, but I'm over the main hurdle, thanks for the help.
 
Last edited: